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Chapter 1: Introduction 
 

Welcome and thank you for your iBlog purchase. This document will teach you all you need 

to know about the iBlog extension. 

 

How to use this document 

 

The information you need is divided into chapters. In some sections you might notice some 

of these two types of paragraphs: 

 

Note: The blue paragraphs contain information which is good to be aware of. They are 

intended for all types of users. 

 

Important: The red paragraphs contain important information, which we strongly advise 

users to read. 
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Chapter 2: Installation instructions 
 

These installation instructions assume that you have either a fresh or a customized 

installation of OpenCart 2.0 or a newer version. 

 

Warning: If your OpenCart is not a fresh installation, files and database backup is highly 

recommended. 

 

1) Unzip the downloaded ZIP file into a new folder. 

 

2) Login to your OpenCart admin panel and go to Extensions > Extension Installer. Upload 

the file iblog.ocmod.zip, which is in the folder you created in Step 1. 

 

Note: If you receive an error "Could not connect as...", this means that your OpenCart FTP 

settings are not properly configured, or FTP is not enabled on your server. To resolve this, 

follow these steps: 

2.1) Go to System > Settings > Edit > FTP and update your FTP settings. After you are done, 

try uploading iblog.ocmod.zip again. If it does not work and you receive the same error 

"Could not connect as...", follow the next step. 

2.2) Go to this link: 

http://www.opencart.com/index.php?route=extension/extension/info&extension_id=1889

2 

and download and install the Quickfix for the OpenCart Extension Installer. After you are 

done, try uploading iblog.ocmod.zip again. 

 

3) Go to Extensions > Modules and click the "Install" button on iBlog, iBlog Category 

Widget and iBlog Widget. Each of these will be followed by the version you have purchased. 

From now on, we will miss that.  

 

4) Go to Extensions > Modifications and click the "Refresh" button on the top right in order 

to rebuild your modification cache. 

 

5) Congratulations! iBlog is now installed.  

http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892
http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892
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Chapter 3: iBlog Basics 
 

How does iBlog work? 

 

If you have followed the steps so far, you have probably noticed that when you went to 

Extensions > Modules, there were three different iBlogs in your Module List. iBlog, iBlog 

Category Widget, and iBlog Widget. So, what is each of these? 

 

You can think of iBlog as your blog "manager". For the better part of itself, this is the back-

end part of the module and is the thing that you will be using to create/edit/delete both 

blog posts and blog categories. More in-depth information on that in chapter 4. 

 

iBlog Category Widget and iBlog Widget, on the other hand, are the panels that will appear 

on the front-end and will contain the blog categories and blog posts respectively. In-depth 

on these in chapters 6 and 7 respectively.  
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Chapter 4: iBlog "Manager" 
 

Control Panel Tab 

 

You are probably all familiar with this tab, since it is part of pretty much every OpenCart 

module out there. The only drop-down menu in it acts as the on/off switch for your module. 

 

Blog Posts Tab 

 

This is the tab listing all(both published and drafted) the blog posts that are currently stored 

in your database.  

 

The Status column shows whether your post is Published or Drafted. Drafted blog posts will 

be visible in this tab only. Published ones will be the one users can see in your store. 

 

The Action column of the table is the only one with functionality within itself. It contains 

two buttons - Edit and Remove.  

 

Clicking the Editbutton will open a new window with the given blog post's details and will 

allow you to edit them. Click the Submit button in the bottom right corner when you are 

done. 

 

Clicking the Remove button opens a conversation window asking you whether you are sure 

you want to remove the given blog post in order to prevent losing information due to 

misclicks. 

 

Warning:Bear in mind, once you remove a blog post, you cannot restore it (unless you have 

database backup). 

 

Blog Categories Tab 

 

This is the place where you will have the chance to create categories, in order to organize 

your blog posts better (both on the front and back-end).  

 

Right above the table listing your categories (if you have any), you will see a button labeled  

"Add new category". Clicking it will result in opening a modal window. 

 

At the top of that window, you can choose a Title for your category. Then you have a text 

area for the Description(the body of your blog post). 
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Then you have the Meta Title, Meta Tag Description and Meta Tag Keywords fields. These 

are all for search engines. In Google, the Meta Title and Meta Tag Description are the 

following: 

 
 

The Meta Tag Keywords are tags that you can insert in your web page to provide search 

engines with information about your pages. These keywords will not be visible anywhere on 

the page itself. 

 

The Parent field. For even better organization, you can give certain categories a parent and 

make them act as sub-categories to that parent. Example: 

 
Initially, the sub-categories will not be shown in the categories widget. They will become 

visible once you click on the parenting category. That said, if you want to create a sub-

category, you should just input the name of the parenting one in the Parent field. 
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The Slug field. This is basically the text that will appear in your URL when you go to a given 

category. You might have noticed that it was automatically filled with your category's name 

when you entered it, replacing spaces with dashes (mind the note about spaces). For the 

abovementioned parenting category, the automatically generated slug will be: 

"recommended-by-isenselabs", and the URL will look as shown: 

 

 
 

Note:The Slug will be functional only if you have SEO URLs enabled from your store settings.  

 

The Image field. At the very bottom of the page, you can upload an image for your category. 

Simply click on the placeholder image and then click on the button with the blue pencil. This 

should result in opening a new image manager modal window with all the images from your 

website. If you want to upload an image from your computer, use the blue Upload button at 

the top left.           

     
 

    

Once you are done with your new category's settings, click Add and you should be able to 

see it in the table. 

 

Blog Listing Tab 

 

Listing URL:Here you will have the URL of your main iBlog page, listing all your blogs. It 

should be available to you even if the extension is disabled.  

 

Add link to the listing in the main menu:Enabling this will make a button for your 

abovementioned main iBlog page appear in the main menu of your home page. It will also 

make 2 more fields become visible below it - Menu Link Title and Menu Link Sort Order. 

 

 Menu Link Title:You can type the label for your button here. It can be different for 

 every language if you are running your store in 2 or more languages. 

 

 Menu Link Sort Order:You can type in a number here and it will use the OpenCart

 sort order, so as to situate your button in the desired place in your main menu. 

 Note: You can check your main menu sort order from Catalog ->Categories 

 

 For the example, I've set my Menu Link Title to "iBlog" and my Menu Link Sort 

Order to "0". It resulted in my main menu looking like this: 
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SEO Options:  These will be basically the same as the previous ones, except for the fact that 

now they will refer to your blog listing page and not for a category one. 

 

Note: Again, mind the note from below the SEO Slug field. 

 

Listing image dimensions:You have two fields here, used for setting width and height (in 

pixels) for the Blog Post's images in the blog listing page. The values I have used for the 

example image are 400x166. Example: 

 

 
 

At the very bottom of that tab, you have a field for some Custom CSS. For anyone familiar 

with CSS, this is the place to implement some custom styles for their listing page. 

Post View Tab 

 

The tab before last for this part of the module is meant to give you a chance to style and add 

some functionalities to your actual blog post pages. 

 

Main image show: This determines whether the image of the blog post will be visible in the 

page. If you Enable it, you will have the option of setting dimensions for it as well. I have it 

Enabled with dimensions 800x333 for the example image. Example: 
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Custom CSS:  As in the previous tab, you have a chance to apply some custom CSS to make 

your post view page more appealing to you. 

 

DisqusComments status:This field gives you the opportunity to activate Disqus comments 

for your blog posts. If you are not familiar with Disqus, click the hyperlink to learn more 

about it. 

 

 DisqusComments Short-name:This field becomes visible once you have enabled the 

previous one. In order for you to use Disqus comments for your blogs, you have to create a 

short-name for your site. You can do that from here. Once you have created the short-

name, just type it in. 

 

DisqusComments in action: 

 

 
 

 

 

AddThis sharing:Enabling this will create a drop-down menu for sharing your blog post by 

using the AddThis platform. It supports most of the social networks, Gmail, Pinterest and 

many more. Example: 

 

 
 

 

 

 

https://disqus.com/
http://disqus.com/admin/create/
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Chapter 5: Creating and formatting a Blog Post 
 

You already know the basics of how your iBlog manager works, so it is time for the most 

essential part of the module - creating and formatting your blog posts. 

 

Creating the blog post 

 

This is quite straight-forward. In the tabs' line of your iBlog 'manager' module settings, there 

is a blue "Add New Post" button.  

 

 
 

Upon clicking it, a modal window with the title of Blog Post Details and some fields will 

open. 

 

Title:  This is where you have to write a title for your blog post. 

 

Excerpt:  You can think of this as either your subtitle, or the short description of your blog 

post. It will appear right beneath the blog post title. Example from the blog listing page: 

 

 
 

Description:  This is the body of your blog post. You can use the text editor to make 

hyperlinks, ordered and unordered lists, insert pictures and even video. Play around with it 

to get used to its features. If you have any problems applying any of them, feel free to use 

the Support tab and open a ticket, so iSenseLabs team can assist you. 

 

Meta Tag Description and Meta Tag Keywords:  These were explained on page 7 about 

categories. Go back if you need a reminder. Same rules apply here, but concerning the given 

blog post and not a category. 

 

Slug:  Refer to page 8. Again, same rules apply here, but for the current blog post and not a 

category. The automatically generated slug for the blog post from the image example will 

be: "for-dummies-how-to-set-up-an-ssl-certificate-in-opencart". You do not need to stick to 

that, any slug that lacks spaces is fine. 
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Image:  Simple. The image for your blog post. It is uploaded via the Image Manager (page 8). 

All options concerning the display of the image on different pages are explained on page 9.  

 

Author:  This is a drop-down menu, listing all the users in your store that have Access 

Permission to the iBlog module. You can check who these are from System ->Users. Choose 

the author that has written the blog post. His/her name will appear below the image in the 

blog post view page along with the date the post has been published on. 

 

 
 

Category:  Here you have a list of all your categories. Check the categories, which you want 

the given blog post to appear in. You can choose neither, one or all of them. 

 

Date Published:  This field will be automatically filled with the date and time as of the 

moment you have clicked the "Add New Post" button. You can change it if you like. 

 

Status:  Choosing the status of your blog post. Go back to page 6, if you need a reminder of 

what Published and Draft mean. 

 

Make it featured: Checking this box will make your blog post featured. Explanation on what 

this changes in Chapter 6. 
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Chapter 6: iBlog Category Widget 
 

This is the part of the module that is used to create panels listing all the existing categories. 

So, how does it work? 

 

Basically, what you have initially is only the thing that will be creating the panels which you  

will be assigning to layouts later. 

 

Creating widgets 

 

From your admin panel, navigate to Extensions ->Modules ->iBlog Category Widget. Click 

the blue Edit button with the pencil in it. Now you should have three fields for Widget 

Name, Custom CSS and Status. 

 

Widget Name:  This is just for your use. It will not be shown anywhere in the front-end. You 

might use it as an indicator for the layout it will be assigned to.  

 

Custom CSS:  This is the only thing, concerning the front-end, that different category 

widgets may differ in. Basically, it is the purpose for you to be able to create different 

category widgets. If you are not planning on or simply cannot apply any CSS, you will be 

more than fine with just one widget that you will apply to all desired layouts. 

 

Status:Again, an on/off switch for the widget you are creating. Note that it does not matter 

whether it is assigned to a layout or not, a widget will not be visible if its status is set to 

disabled. 

 

When you are ready to proceed with creating your first widget, simply click the blue Save 

button in the top right corner. 

  

If you go to the Module List now, you should see a new module in the list by the name of 

iBlog Category Widget>{Widget_Name}. I have used Category Page as a widget name for 

the example. Example: 
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Assignment to layout/s 

 

By now, we have the panel created, we just have to find place for it somewhere in your 

store. To do so, we have to assign it to a layout. 

 

Navigate to System ->Design ->Layouts. Let's say you want a panel listing all categories in 

the left column of your Home page. Click the blue Edit button with the pencil in the Home 

row. In the second table, click the blue Add Module button with the + in it. This should add 

another row to your table. In the Module column, find iBlog Category Widget -

>{Widget_Name}. From the Position column, choose Column Left and set the Sort Order 

from the last column to 0, just to make sure the panel is on top of the column. This is how 

the table row looks like: 

 

 
 

To make sure everything is saved, scroll up and click the blue Save button in the top right 

corner of the page. 

 

Navigate to your store's homepage and you should see a panel on the left, listing all your 

categories. Example: 

 

 
 

You can assign this widget to all desired layouts. 
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Chapter 7: iBlog Widget 
 

Alright, you have a widget to make/control your categories. iBlog Widget is the same thing 

for posts.  

 

Creating widgets 

 

For the better part of itself, this widget is the same as the previous one. That said, creating 

widgets is a lot similar. 

 

From your admin panel, navigate to Extensions ->Modules ->iBlog Widget. Click the blue 

Edit button with the pencil in it. Now you should have four fields for Widget Name, Show 

Featured Blogs, Custom CSS and Status. 

 

Widget Name:  Same as before, this is just for your use. It will not be shown anywhere in 

the front-end. You might use it as an indicator for the layout it will be assigned to. 

 

Custom CSS:  Yet again, some chance to personally customize the panel for those of you 

familiar with basic web design (particularly CSS). 

 

Show Featured Blogs:  As you might remember, it was mentioned (page 13) that when you 

are creating a blog post, you can choose whether to make it featured or not. So, now you 

are about to find out exactly what this stands for. The field we are currently talking about is 

a drop-down menu with 2 possible values - Enabled or Disabled. Needless to say, disabling 

it will result in not showing any featured blog posts along with the panel. Enabling the menu 

will result in the appearance of 2 more fields for Width and Height. 

 

 Width & Height:   These are the dimensions (in pixels) of the image of the featured 

blog post that will be shown in the panel.  

 

 

 

 Note:  Featured blogs appear in a different panel than all the other blog posts. This 

panel can only contain one blog post and that will be the one created last (date-wise) and 

marked as featured. 

 

 

 

 

 



 

iBlog Documentation 
 

 

               http://isenselabs.com 
 

               http://isenselabs.com/users/support 16 

 

Here is an example of the Featured Blog Post panel with dimensions of 200x200(the grey 

field the arrow is pointing at): 

 

 
 

As for the last field - Status:  the well-known on/off switch of the widget. Note that it does 

not matter whether it is assigned to a layout or not, a widget will not be visible if its status is 

set to disabled. 

 

As before, when you are ready to proceed with creating your widget, simply click the blue 

Save button in the top right corner. 

  

If you go to the Module List now, you should see a new module in the list by the name of 

iBlogWidget>{Widget_Name}. I have used iBlog-Home as a widget name for the example, 

since I will be assigning it to the layout of Home. Example: 

 

 
 

 

Assignment to layout/s 

 

It is again an easy-to-do and not very time-consuming operation. 

 

Navigate to System ->Design ->Layouts. Let's say you want a panel listing all posts at the top 

of your Home page. Click the blue Edit button with the pencil in the Home row. In the 

second table, click the blue Add Module button with the + in it. This should add another row 

to your table. In the Module column, find iBlogWidget ->{Widget_Name}. From the 
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Position column, choose Content Top and set the Sort Order from the last column to 0, just 

to make sure the panel is on top of the page. This is how the table row looks like:  

 

 
 

To make sure everything is saved, scroll up and click the blue Save button in the top right 

corner of the page. 

 

Navigate to your store's homepage and you should see two panels at the top. The first one 

showing the latest featured blog post (if you have a featured blog post and have "Show 

Featured Blogs" enabled from the widget). The second one will be the panel listing all your 

blog posts. This is how the panels on my home page look: 
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Chapter 8: Uninstalling iBlog 
 

This process describes how to uninstall iBlog from your store. 

 

Warning: This action cannot be reversed. It is highly recommended that you create a file 

and database backup just in case. 

 

To uninstall iBlog, navigate to Extensions ->Modules. Find the iBlog module, iBlog Category 

Widget and iBlog Widget. In the Action column of each of these, there should be a red 

Uninstall button. Upon clicking it, you will be asked whether you are sure you want to 

proceed. Provided you say yes, the module will be uninstalled from your website. 

 

Warning: Once you have uninstalled each of these you lose all the information related to 

them. That said, if you have not done the abovementioned backup, there is no way to 

retrieve the deleted information. 
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Chapter 9: Getting support 
 

If you have a valid iSenseLabs license for the iBlog module, this means you have access to 

the iSenseLabs support system on the following address: 

 

http://isenselabs.com/users/support 

 

If you have any questions, comments or recommendations, feel free to open up a support 

ticket in our system. A support specialist will assist you as soon as possible. 

 

Thank you for using our product! 

 

http://isenselabs.com/users/support
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