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Welcome 

 

Hello and thank you for your interest in OrderReviews. This document is an introduction to 
OrderReviews’s functionality. It is recommended that you familiarize yourself with the contents of 
this document prior to using OrderReviews.  

How to use this document? 

 

The information you need is divided into chapters. In some sections you might notice some 

of the following types of paragraphs which give you extra information: 

 

Note: The blue paragraphs contain information which is good to be aware of. They are 

intended for all types of users. 

 

Important: The red paragraphs contain important information, which we strongly advise 

users to read. 
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Chapter 01: Installation Instructions 

These installation instructions assume that you have either a fresh or a customized installation of 
OpenCart 2.0 or newer. 

Warning: If your OpenCart is not a fresh installation, files and database backup is highly 

recommended. 

 

Install using the OpenCart Extension Installer 

1) Unzip the downloaded ZIP file into a new folder 
2) Login to your OpenCart admin panel and go to Extensions > Extension Installer. Upload the 

file orderreviews.ocmod.zip, which is in the folder you created in Step 1. 

Note: If you receive an error "Could not connect as...", this means that your OpenCart FTP 

settings are not properly configured, or FTP is not enabled on your server. To resolve this, 

follow these steps: 

 2.1)   Go to System > Settings > Edit > FTP and update your FTP settings. After you are done, 
try uploading OrderReviews again. If it does not work and you receive the same error "Could not 
connect as...", follow Step 2.2: 

 2.2)   Go to this link: 
http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892 and 
download and install the Quickfix for the OpenCart Extension installer. After you are done, try 
uploading OrderReviews again. 

3)   Go to Extensions > Modules > OrderReviews and click the "Install" button ("+" sign). 

4)   Go to Extensions > Modifications and click the "Refresh" button on the top right. 

5)   Congratulations! OrderReviews is now installed and configured. You can access it from 
Extensions > Modules > OrderReviews. 

 

Manual Installation 

1) Unzip the downloaded ZIP file into a new folder 
2) Navigate to this folder and find the file orderreviews.ocmod.zip. Extract this file. 
3) Navigate to the extracted folder. You will notice an upload/ folder. 
4) [Optional] Some OpenCart stores have their admin folder renamed and some extra 

languages installed. If necessary, rename the admin/ folder and the 
admin/language/english/ folder to match your OpenCart setup. 

5) Upload the contents of this folder to your OpenCart store, making sure to preserve the 
directory structure. 

6) The extracted orderreviews.ocmod.zip also contains an install.xml file. Rename the file to 
install.ocmod.xml. 

7) Login to your OpenCart admin panel. Once you do that, go to Extensions -> Extension 
Installer. Upload the file install.ocmod.xml and wait for the success message. 

8) Go to Extensions > Modules and find OrderReviews and click the “Install” button ("+" sign).  
9) Go to Extensions > Modifications and click the "Refresh" button on the top right. 

http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892%20
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10) Congratulations! OrderReviews is now installed and configured. You can access it from 
Extensions > Modules > OrderReviews. 
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Chapter 02: User Interface 

 

The User Interface of OrderReviews is accessible from Admin > Extensions > Modules > 
OrderReviews > [Edit] 

This is where you can edit and customize your OrderReviews module. There is a single “Control 
Panel” tab with options and information: 

 

Control Panel tab 

Once you open the OrderReviews module, the Control Panel tab looks like this: 

 

In order to enable the module, set the Module Status option to Enabled. After you enable the 

module, more options will appear below: 

 

 

 

This is the main tab of the module. We will now go through each option one by one. 

Status:  This option enables or disables the OrderReviews module. 



 

OrderReviews Documentation 
 

                    

                  http://isenselabs.com 
 

                  http://isenselabs.com/users/support 7 

 

Cron job:  

Note: The CRON daemon is a long running process that executes commands at specific 

dates and times. OrderReviews uses CRON job service in order to check for completed 

orders and send emails to customers automatically. 

This option provides you with information on how to set up the CRON job correctly. You can press 
the “How to set up the CRON job?” button for more information. If you also wish to receive 
notification emails when the CRON job is executed, you can check the checkbox underneath the 
button. 

 

Send BCC to store owner: By enabling this option you will receive an email to your OpenCart email 
address with a copy from each email OrderReviews sends to a customer. 

The following options you can configure an email template that will suite your specific needs. 

 

You can create a new email template from the “Add New ReviewMail” button or you can choose 
from the once that you already created. 

 

ReviewMail status: This option will enable or disable the selected mail review configuration. 
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ReviewMail name: This field give you the ability to set a name of the template which will show up 
on the left column.  

Order status: Here you can select the order status at which the selected email review will be sent to 
the customer. 

Customer group: You can specify the customer groups, that will receive selected mail review 
template. 

Message delay: Here you can set after how many days the notification email will be sent.  

Note: If you set the delay to 0, the email will be sent immediately after you run the CRON 

job and if the conditions are met. 

Select orders by: This option specifies how to select orders. You can select them by Date Added or 
by Date Modified.  

Review type: With this option you can choose whether there should be one form for all products in 
a purchase or each product in the given purchase should have an individual form. 

Type of discount: With this option you get to choose which type of discount you want the customer 
to receive. You have three options: 

- No discount:  There will be no discount 

Note1: If you choose this option, you will have to remove the following codes from the mail 

template: {discount_code}, {discount_value}, {total_amount} and {date_end}.  

Note2: If you choose this option, the input fields “Discount”, “Total Amount”, “Discount 

validity” and “Discount mail status” will not be available. 

 
- Fixed amount: Choosing this option will enable you to set a fixed 

amount with which the customer will be discounted after 
submitting a review. 

- Percentage: Choosing this option will enable you to set a 
percentage discount with which the customer will be discounted 
after submitting a review. 
 

Discount: Here you can set the discount percent or value. 

Total amount: With this option you can specify the minimum amount the customer has to spend in 
order to use the coupon code. 

Discount validity: Here you can specify how many days the discount code will be active for after 
sending the reminder. 

Discount mail status: The customer will receive information about their discount, after he/she 
submits a review, directly in the success page. If you enable this option, however, the customer will 
also receive an email with the discount information. 

Note: Enabling this option will create a second rich text editor at the bottom of the page 

with which you can create the email template for the discount mail. 

Review Mail Settings: The following are settings for the Review Mail. You can customize the mail as 
you wish. 
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Subject: This option will set the subject of the mail. 

Message:  Here you can use the text editor to customize the message template.  

Note: You can use shortcodes in order to generalize the message template: 

With the help of shortcodes you can save a lot of time writing emails. You can say, for example 
“Hello {first_name} {last_name}” which means that every customer will receive a personalized 
greeting with their own name in it. There is no need to write personalized emails to each one of your 
customers. 

 

We will briefly go through each one of the shortcodes: 

{first_name} – Inserting it in the email will generate the customer’s first name 

{last_name} – This will generate the last name 

{order_products} – This shortcode is used to output the ordered products 

{review_form} – This shortcode will generate a review form in the email itself. 

{order_id} – This will show up the Order ID 

{reviewmail_link} – This shortcode will generate a link which can redirect the user to the online form 
of the email. 

Select date format for the end date of coupon validity: You can choose the date format for the 
coupon validity. You can choose from four different formats:

 

Here is an example what November 15, 2015 would look like in each of formats: 

dd-mm-yyyy – 15-11-2015 

mm-dd-yyyy – 11-15-2015 

yyyy-mm-dd – 2015-11-15 

yyyy-dd-mm – 2015-15-11 
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Chapter 03: Schedule your messages using CRON Jobs 
 

CRON is a time-based job scheduler in UNIX-like operating systems. By means of it, you can 

schedule tasks (messages, in our case), which are usually referred to as "CRON Jobs". Using 

CRON Jobs allows you to automate your messages and send a given OrderReview email 

automatically at a given moment in time. 

 

Note: The explanations on how to set a CRON job here are for cPanel users. Though the 

process is similar for most web hosting control panels, it might have slight differences. If you 

need any help setting CRON jobs on a different control panel, feel free to contact 

iSenseLabs support team for assistance. 

 

Important:  If your server does not support CRON Jobs, you can try using services such as  

easycron.com, setcronjob.com or others, which can provide you with this feature. 

 

 

Setting a CRON Job 

 

First off, you need to navigate to your module's settings. Go to the Control Panel tab. 

Opposite of the second field ("Keep log"), you will find a button labeled "How to set up the 

cron job?".  

 

 
 

Upon clicking it, a modal window will pop up. This window contains the command you need 

to activate the CRON job (shown in the picture below). Copy it. 
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Now, navigate to your cPanel. In the Advanced section, find Cron Jobs and click it. 

 

 
 

You will be redirected to the following page: 
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To add a CRON job, you must first determine how often the CRON job should activate the  

e-mail-sending script. This is done from the "Common Settings" drop-down menu. 

 

WARNING:  Make sure you set the CRON job to at least "Once per day", otherwise you will 

end up spamming your customers with multiple e-mails a day. 

 

Then,  from the Minute and Hour fields, choose the given hour you want the CRON to run at 

(the values used for the example are 0 and 0, which means the CRON will run at 00:00 every 

day). 

 

And last but not least, you should paste the command you copied earlier in the "Command" 

field. It should look something like this: 

 

php/home/orderreviewsdemo/public_html/oc2/vendors/orderreviews/sendEmails.php 

 

Important: Bear in mind the command should not include the "0 0 * * *".     

 

Important: Keep in mind that some servers require the full path to the php extension, which 

on most of the servers is usr/bin/php. In such cases, you just have to change the beginning 

of the command from “php” to “usr/bin/php”. If this does not make CRON jobs work, it 
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means the php extenion is at a different place (the path is not correct). In that case, contact 

your hosting provider for more information. 

 

Once you have copied it, click the "Add New Cron Job" button and the CRON job you have 

been creating should appear in the "Current Cron Jobs" section below as shown: 

 

 
 

Congratulations! You have set up your CRON job. 
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Chapter 04: Functionality 

 

In this chapter we are going to take a look at how the OrderReviews module works. 

For the following example we have set the OrderReviews module to send review mail when the 
order status is “Complete”.  Once the administrator changes the order status to “Complete”, the 
user will receive a review email. The customer can make the review directly from the email and click 
the “Submit Review” button in order to submit it to the store.  

 

 

After the customer submits their review, they will be redirected to the “Thank you” page where they 
will see information about their coupon code. 

 

Since we have enabled the Discount mail status option, the customer also receives an email with 
information about their coupon code. 
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Now you can go to your Open Cart Admin Panel in Catalog > Reviews and change the status of the 
customer review from Disabled to Enabled. 

 

One you enable the customer’s review, it will be available in the “Reviews” tab in the product 
description. 
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Chapter 05: Uninstalling OrderReviews 
 
This process describes how to uninstall OrderReviews from your store. 

 

Note: This action cannot be reversed. It is highly recommended that you create a file and a 

database backup just in case.  

 

To uninstall OrderReviews, navigate to Extensions -> Modules. Find the OrderReviews module. In 

the Action column there should be a red Uninstall button. Upon clicking it, you will be asked 

whether you are sure you want to proceed. Provided you say “Yes”, the module will be uninstalled 

from your website. 

 

Important: Once you have uninstalled the module you will lose all the information and 

settings related to it. That said, if you have not done the abovementioned backup, there is 

no way to retrieve the deleted information. 
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Chapter 06: Support 
 

 

You are entitled with one year of Free Premium Support upon purchasing OrderReviews. As soon as 
you make your purchase, you will have an associated OrderReviews purchase in your iSenseLabs 
account in: 
http://isenselabs.com/users/purchases 

An OrderReviews license key is associated with your OrderReviews purchase. You can insert this 
license key in the Support tab of OrderReviews. This will activate your license and associate it with 
your website domain. For more information, please visit our Support Policy here: 
http://isenselabs.com/pages/supportpolicy 

The Support tab also contains links to our support tickets, community forums and sales e-mail. Feel 
free to contact us if you have any questions. 

 

  

http://isenselabs.com/users/purchases
http://isenselabs.com/pages/supportpolicy
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Final Words 

Thank you for your interest in OrderReviews. You can also take a look at our blogpost on 
OrderReviews Q&A at https://isenselabs.com/posts/orderreviews-qa. If you experience any 
difficulties, feel free to open a ticket in http://isenselabs.com/users/support. We will gladly assist as 
soon as possible. 

https://isenselabs.com/posts/orderreviews-qa
http://isenselabs.com/users/support

