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Welcome 

 

Hello and thank you for your interest in AbandonedCarts. This document is an introduction to 
AbandonedCarts’s functionality. It is recommended that you familiarize yourself with the contents of 
this document prior to using AbandonedCarts.  

How to use this document? 

 

The information you need is divided into chapters. In some sections you might notice some 

of the following types of paragraphs which give you extra information: 

 

Note: The blue paragraphs contain information which is good to be aware of. They are 

intended for all types of users. 

 

Important: The red paragraphs contain important information, which we strongly advise 

users to read. 

  



 

AbandonedCarts Documentation 
 

                    

                  http://isenselabs.com 
 

                  http://isenselabs.com/users/support 4 

 

Chapter 01: Installation Instructions 

These installation instructions assume that you have either a fresh or a customized installation of 
OpenCart 2.0 or newer. 

Warning: If your OpenCart is not a fresh installation, files and database backup is highly 

recommended. 

 

Install using the OpenCart Extension Installer 

1) Unzip the downloaded ZIP file into a new folder 
2) Login to your OpenCart admin panel and go to Extensions > Extension Installer. Upload the 

file abandonedcarts.ocmod.zip, which is in the folder you created in Step 1. 

Note: If you receive an error "Could not connect as...", this means that your OpenCart FTP 

settings are not properly configured, or FTP is not enabled on your server. To resolve this, 

follow these steps: 

 2.1)   Go to System > Settings > Edit > FTP and update your FTP settings. After you are done, 
try uploading AbandonedCarts again. If it does not work and you receive the same error "Could not 
connect as...", follow Step 2.2: 

 2.2)   Go to this link: 
http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892 and 
download and install the Quickfix for the OpenCart Extension installer. After you are done, try 
uploading AbandonedCarts again. 

3)   Go to Extensions > Modules > AbandonedCarts and click the "Install" button ("+" sign). 

4)   Go to Extensions > Modifications and click the "Refresh" button on the top right. 

5)   Congratulations! AbandonedCarts is now installed and configured. You can access it from 
Extensions > Modules > AbandonedCarts. 

 

Manual Installation 

1) Unzip the downloaded ZIP file into a new folder 
2) Navigate to this folder and find the file abandonedcarts.ocmod.zip. Extract this file. 
3) Navigate to the extracted folder. You will notice an upload/ folder. 
4) [Optional] Some OpenCart stores have their admin folder renamed and some extra 

languages installed. If necessary, rename the admin/ folder and the 
admin/language/english/ folder to match your OpenCart setup. 

5) Upload the contents of this folder to your OpenCart store, making sure to preserve the 
directory structure. 

6) The extracted abandonedcarts.ocmod.zip also contains an install.xml file. Rename the file 
to install.ocmod.xml. 

7) Login to your OpenCart admin panel. Once you do that, go to Extensions -> Extension 
Installer. Upload the file install.ocmod.xml and wait for the success message. 

8) Go to Extensions > Modules and find AbandonedCarts and click the “Install” button ("+" 
sign).  

http://www.opencart.com/index.php?route=extension/extension/info&extension_id=18892%20
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9) Go to Extensions > Modifications and click the "Refresh" button on the top right. 
10) Congratulations! AbandonedCarts is now installed and configured. You can access it from 

Extensions > Modules > AbandonedCarts. 
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Chapter 02: User Interface 

 

The User Interface of AbandonedCarts is accessible in Admin > Extensions > Modules > 
AbandonedCarts > [Edit] 

This is where you can edit and customize your AbandonedCarts module. There are 6 tabs with 
options and information: 

 

Control Panel tab 

 

 

 

This is the main tab of the module. We will now go one by one through each option. 

The first option AbandonedCarts status is for enabling and disabling the module. You can choose the 
format of the date with Date Format option. You can also choose whether or not to apply taxes from 
the Apply Taxes option. When you enable the Send BCC to store owner option you will receive an 
email to your OpenCart email address with a copy from each email AbandonedCarts sends to a 
customer. With the Scheduled tasks option you can enable automatic sending of the email to the 
customers who abandoned their carts. 
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Abandoned Carts tab

 

 

In this tab you can see a list of all the abandoned carts. On the top of the page you are offered three 

different views of the Abandoned Carts list: 

 

1. Default (not notified) – Here you will see all the abandoned cart entries, that have not been 

notified yet. 

2. Already notified (at least once) – Now you will be able to see all the abandoned cart entries, 

that have been notified at least once. 

3. Ordered – This view shows only Abandoned Cart entries such that the customer has been 

notified and has ordered the product after the notification. 

 

Each Abandoned Cart entry looks like this: 

 

ID – This is the unique ID number of each abandoned cart 

Customer Info – This is information about the customer such as Name, Email Address, Phone 

number etc.   

Note: If the customer has not been logged in while abandoning the cart, you will see “(not 

provided)” in their Customer Info column. 
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Shopping Cart – This column shows the products that were in the cart when the customer 

abandoned it. 

Date & Time – Information about the date and time spent by the customer in your web store. 

IP – The IP Address of the customer.  

  

When you click on “Check IP” button you will be redirected to http://www.checkip.com/ and 
provided with information about the customer’s IP Address.

  

http://www.checkip.com/
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Status & Actions -  Here you can see if the customer has been notified and if he/she has ordered. 
Also, you can send a reminder or delete the entry. 

Note: You will not be able to send a reminder if the abandoned cart belongs to a guest 

customer who has not provided their email address. 

 

At the bottom of the page there are two buttons:

 

“Remove all empty record” – Removes all the records which do not have emails. 

“Remove all” – Removes all the records from the list. 

 

 

Mail Template tab 

In this tab you can customize the template for the emails that AbandonedCarts module is going to 
send to customers. You can also create several templates for convenience.  
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In order to create a template you need to click on “Add New Template”.  The new template will be 
called “Template 1” by default.

 

 

After you create a template, a list of customization options will appear as in the screenshot:

 

 

 

Here is what each of the customizing options mean: 

Template 1 status: This option enables or disables the selected template configurations 

Template 1 name: This option changes the name of the template that will show up in the template 
list 

Message delay: Here you can set after how many days the notification email will be sent.  

Note: If you set the delay to 0, the email will be sent immediately after you run the CRON job 

and if the conditions are met. 

Type of discount: With this option you get to choose which type of discount you want the email to 
contain. You have three options: 
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- No discount:  There will be no discount 

Note1: If you choose this option, you will have to remove the following codes from the mail 

template: {discount_code}, {discount_value}, {total_amount} and {date_end}.  

Note2: If you choose this option, the input fields “Discount”, “Total Amount”, “Discount 

validity” and “Apply the discount for” will not be available. 

 
- Fixed amount: Choosing this option will enable you to set a fixed 

amount with which the customer will be discounted when 
receiving the email. 

- Percentage: Choosing this option will enable you to set a 
percentage discount with which the customer will be discounted 
when receiving the email. 
 

Discount: Here you can set the discount percent or value. 

Total amount: With this option you can specify the minimum amount the customer has to spend in 
order to use the coupon code. 

Discount validity: Here you can specify how many days the discount code will be active for after 
sending the reminder. 

Apply the discount for: Here you can choose the products that the discount will applied to. You have 
two options: 

- All products in the store: The discount will be valid for all the 
products in the store 

- Products in the cart: The discount will be valid only for those 
products that were in the abandoned cart 

Product image dimensions: With this option you can specify the width and height of the product 
image that will appear in the email. 

Message to the customer:  Here you can use the text editor to customize the message template.  

Note: You can use shortcodes in order to generalize the message template: 

With the help of shortcodes you can save a lot of time writing emails. You can say, for example 
“Hello {fisrtname} {lastname}” which means that every customer will receive a personalized 
greeting with their own name in it. There is no need to write personalized emails to each one of your 
customers. 
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Additional options: Here you can find additional options for the emails. 

 

 

Statistics tab 

In this tab you can see statistics about the coupons and the abandoned carts.  

 

You are presented with 2 pie charts showing you the total number of coupons and abandoned carts. 
On the right side of the page there is a table with more detailed information about the coupons as 
well as the abandoned carts. You can also track the last visited pages and how many times they were 
accessed. 
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Coupons tab 

 In the coupons tab you can see all the coupons that have been distributed to the customers. You 
also have 2 views to choose from: “Given Coupons” and “Used coupons”.

 

As the names suggest in “Given Coupons” view you can see all the coupons that have been sent to 
customers and in “Used Coupons” view you can see the coupons that have been already used by 
customers.  

One Coupon entry looks like this: 

 

 

It has the following attributes: 

Coupon Name: This is the name of the coupon. It usually starts with “AbCart” and contains the email 
of the customer in brackets. 

Code: In this column is the actual coupon code. 

Discount: Here it is shown the amount of the discount. 

Date Start: This is the starting date of the coupon code 

Date End: This is the ending date of the coupon code validity. 

Status: The status of the coupon 

Date Added: This is the date and time when the coupon was added. 

 

 

 

 

 

 

 

 



 

AbandonedCarts Documentation 
 

                    

                  http://isenselabs.com 
 

                  http://isenselabs.com/users/support 14 

 

Chapter 03: Sending Emails 

 

In this chapter we are going to cover how you can send emails with coupons to the customers who 
abandoned their carts. In general, you have two options. You can either do it manually or set up a 
CRON job to send emails automatically. We are going to take a closer look at those two methods. 

 

Sending Emails Manually 

In order to send an email with a coupon to a customer who abandoned their cart you need to go to 
Abandoned Carts tab and click the “Send reminder” button.  

Note: The “Send reminder” button is only available for the entries which have email address 

in their “Customer Info” Column. 

 

 

After you press the “Send reminder” button a pop-up window will appear offering you one last 
chance to edit the Email that you are sending. After reviewing it, press the “Send mail!” button in 
the bottom right corner and you are all set.  
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The customer receives their reminder email with a coupon in it. 
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Automatic Email Sending 

Sending email manually can be time-consuming if you have a lot of abandoned carts. This is why 

AbandonedCarts has the function to send email reminders automatically.  

Important: If you want to use the scheduling features, your server has to 

support Cron functions. The cron daemon is a long running process that executes commands 

at specific dates and times. You can check if your server supports Cron commands by clicking 

the Test Cron button.  

 

- If your server does support Cron jobs, but this script shows that the feature is disabled, 

this means that the automatic creation of Cron commands is disabled. In that case, 

you can use this URL string -

{path_to_your_site}/vendors/abandonedcarts/sendReminder.php - in your hosting 

config panel.  

- If your server does not support Cron jobs, you can click on the “My server does not 

support cron jobs” button in order to receive instruction for alternative cron 

solutions.

 
 

 

Anyway, in order to enable automatic sending you need to go to Control Panel tab end set the 

Scheduled tasks option to be Enabled. Once you do that, several new options will appear.  
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We will take a look at each one of the new options. 

Type: Here you can choose the type of the schedule. You have two options: 

- Fixed dates: you can specify fixed dates and time for sending the 

email reminders 

- Periodic: you can configure the sending of email reminders to be 

done every day/wee/month/year at specific time 

Schedule: With this option you will set the schedule.  

Note: You will see the options for the fixed dates functionality or the periodic functionality 

depending on the Type option. 

 

 Important: Keep in mind that the scheduling time is a global variable for all stores in your 

OpenCart. 
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Chapter 4: Uninstalling AbandonedCarts 
 
This process describes how to uninstall AbandonedCarts from your store. 

 

Note: This action cannot be reversed. It is highly recommended that you create a file and a 

database backup just in case.  

 

To uninstall AbandonedCarts, navigate to Extensions -> Modules. Find the AbandonedCarts 

module. In the Action column there should be a red Uninstall button. Upon clicking it, you will be 

asked whether you are sure you want to proceed. Provided you say “Yes”, the module will be 

uninstalled from your website. 

 

Important: Once you have uninstalled the module you will lose all the information related to 

it. That said, if you have not done the abovementioned backup, there is no way to retrieve 

the deleted information. 
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Chapter 5: Support 
 

 

You are entitled with one year of Free Premium Support upon purchasing AbandonedCarts. As soon 
as you make your purchase, you will have an associated iSenseLabs purchase in your iSenseLabs 
account in: 
http://isenselabs.com/users/purchases 

An AbandonedCarts license key is associated with your AbandonedCarts purchase. You can insert 
this license key in the Support tab of AbandonedCarts. This will activate your license and associate it 
with your website domain. For more information, please visit our Support Policy here: 
http://isenselabs.com/pages/supportpolicy 

The Support tab also contains links to our support tickets, community forums and sales e-mail. Feel 
free to contact us if you have any questions. 

 

  

http://isenselabs.com/users/purchases
http://isenselabs.com/pages/supportpolicy
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Final Words 

Thank you for your interest in AbandonedCarts. You can also take a look at our blogpost on 
AbandonedCarts Q&A at https://isenselabs.com/posts/abandonedcarts-qa. If you experience any 
difficulties, feel free to open a ticket in http://isenselabs.com/users/support. We will gladly assist as 
soon as possible. 

https://isenselabs.com/posts/abandonedcarts-qa
http://isenselabs.com/users/support

